当前位置:在线查询网 > 在线百科全书查询 > AC自动机

AC自动机_在线百科全书查询


请输入要查询的词条内容:

AC自动机




概述


Aho-Corasick automation,该算法在1975年产生于贝尔实验室,是著名的多模匹配算法之一。

要学会AC自动机,我们必须知道什么是Trie,也就是字母树。Trie树,又称单词查找树键树,是一种树形结构,是一种哈希树的变种。典型应用是用于统计和排序大量的字符串(但不仅限于字符串),所以经常被搜索引擎系统用于文本词频统计。它的优点是:最大限度地减少无谓的字符串比较,查询效率比哈希表高。

应用


一个常见的例子就是给出n个单词,再给出一段包含m个字符的文章,让你找出有多少个单词在文章里出现过。

要搞懂AC自动机,先得有模式树(字典树)Trie和KMP模式匹配算法的基础知识。AC自动机算法分为3步:构造一棵Trie树,构造失败指针和模式匹配过程。

如果你对KMP算法和了解的话,应该知道KMP算法中的next函数(shift函数或者fail函数)是干什么用的。KMP中我们用两个指针i和j分别表示,A[i-j+ 1..i]与B[1..j]完全相等。也就是说,i是不断增加的,随着i的增加j相应地变化,且j满足以A[i]结尾的长度为j的字符串正好匹配B串的前 j个字符,当A[i+1]≠B[j+1],KMP的策略是调整j的位置(减小j值)使得A[i-j+1..i]与B[1..j]保持匹配且新的B[j+1]恰好与A[i+1]匹配,而next函数恰恰记录了这个j应该调整到的位置。同样AC自动机的失败指针具有同样的功能,也就是说当我们的模式串在Tire上进行匹配时,如果与当前节点的关键字不能继续匹配的时候,就应该去当前节点的失败指针所指向的节点继续进行匹配。

下面看一道例题

Problem Description

In the modern time, Search engine came into the life of everybody.Wiskey also wants to bring this feature to his image retrieval system.Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched. To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.

Input

First line will contain one integer means how many cases will follow by.

Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)

Each keyword will only contains characters ''a''-''z'', and the length will be not longer than 50.

The last line is the description, and the length will be not longer than 1000000.

Output

Print how many keywords are contained in the description.

Sample Input

1 5 she he say shr her yasherhs

Sample Output

3

AC自动机 C++ 源代码


#include <iostream>

using namespace std;

const int kind = 26;

struct node{

node *fail; //失败指针

node *next[kind]; //Tire每个节点的26个子节点(最多26个字母)

int count; //是否为该单词的最后一个节点

node(){ //构造函数初始化

fail=NULL;

count=0;

memset(next,NULL,sizeof(next));

}

}*q[500001]; //队列,方便用于bfs构造失败指针

char keyword[51]; //输入的单词

char str[1000001]; //模式串

int head,tail; //队列的头尾指针

void insert(char *str,node *root){

node *p=root;

int i=0,index;

while(str[i]){

index=str[i]-''a'';

if(p->next[index]==NULL) p->next[index]=new node();

p=p->next[index];

i++;

}

p->count++;

}

void build_ac_automation(node *root){

int i;

root->fail=NULL;

q[head++]=root;

while(head!=tail){

node *temp=q[tail++];

node *p=NULL;

for(i=0;i<26;i++){

if(temp->next[i]!=NULL){

if(temp==root) temp->next[i]->fail=root;

else{

p=temp->fail;

while(p!=NULL){

if(p->next[i]!=NULL){

temp->next[i]->fail=p->next[i];

break;

}

p=p->fail;

}

if(p==NULL) temp->next[i]->fail=root;

}

q[head++]=temp->next[i];

}

}

}

}

int query(node *root){

int i=0,cnt=0,index,len=strlen(str);

node *p=root;

while(str[i]){

index=str[i]-''a'';

while(p->next[index]==NULL && p!=root) p=p->fail;

p=p->next[index];

p=(p==NULL)?root:p;

node *temp=p;

while(temp!=root && temp->count!=-1){

cnt+=temp->count;

temp->count=-1;

temp=temp->fail;

}

i++;

}

return cnt;

}

int main(){

int n,t;

scanf("%d",&t);

while(t--){

head=tail=0;

node *root=new node();

scanf("%d",&n);

getchar();

while(n--){

gets(keyword);

insert(keyword,root);

}

build_ac_automation(root);

scanf("%s",str);

printf("%d\",query(root));

}

return 0;

}

相关分词: AC 自动机 自动 动机